Sitecore WFFM custom save actions not working in CD environments

Recently we had an issue in UAT site where WFFM custom save action was found not working on CD servers, but it was absolutely fine on CM server.

WFFM-SaveAction

After checking we found that settings that are required to be done on Sitecore.Forms.config on CD servers were missing, also- we observed that “Custom Action” checkbox was not checked on the custom save action item.

So, here are couple of things to double check when we see custom save action not working in CD servers:

  1. Make sure “Client Action” is checked on WFFM custom save action.ClientAction
  2. Make sure to configure CD server config as per WFFM Installation guide which includes:
    • On all the CD servers, in the \Website\App_Config\Include\Sitecore.Forms.Config file, remove or disable the following sections:
      • In the <sitecore> section, remove:
      • <!—HOOKS–>
        <hooks> <!—remote events hook–>
        <hook type=”Sitecore.Form.Core.WffmActionHook, Sitecore.Forms.Core”/>
        <hooks>

      • In the <events> section, remove:
      • <!–Remote events handler–>
        <event name=”wffm:action:remote”>
        <handler type=”Sitecore.Form.Core.WffmActionHandler, Sitecore.Forms.Core” method=”OnWffmActionEventFired” > <param name=”actionManager” ref=”/sitecore/wffm/wffmActionExecutor” /> </handler>
        </event>

      • Add the following node to the <settings> section:
      • <setting name=”WFM.IsRemoteActions” value=”true” />

      • Configure the following node according to the name of the connection string related to the target database. For example “web”.
      • <setting name=”WFM.MasterDatabase” value=”web” />

Hope this helps!

Happy learning 🙂